В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
karo35
karo35
05.03.2022 23:42 •  Информатика

Написать программу с++ заполнить массив двенадцатью первыми членами последовательности в которой первые два члена равны 1, а каждый следующий равен сумме двух предыдущих и вывести на экран через запятую

Ответ:
КатяЗюзина
КатяЗюзина
16.08.2020 13:01
#include <iostream>
using namespace std;

int main() {
int n=12;
int a[n];
a[0]=1;
a[1]=1;
for (int i=2; i<n; i++){
 a[i] = a[i-2]+a[i-1];
}
for (int i=0; i<n-1; i++){
 cout << a[i] << ",";
}
cout << a[n-1] << "\n";
return 0;
}

Результат:
1,1,2,3,5,8,13,21,34,55,89,144
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?