В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
4ebybek
4ebybek
17.06.2021 20:05 •  Информатика

Составьте программу для паскаля. даны три числа. найти среди них произведение и количество отрицательных.

Ответ:
emilyblack80
emilyblack80
07.10.2020 03:58
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadInteger3('Введите три целых числа:');
  var (p,k):=(int64(1),0);
  if a<0 then begin p:=p*a; k+=1 end;;
  if b<0 then begin p:=p*b; k+=1 end;
  if c<0 then begin p:=p*c; k+=1 end;
  Writeln('Произведение чисел равно ',p);
  Writeln('Количество отрицательных чисел равно ',k);
end.

Пример
Введите три целых числа: 12345 -67891011 -1213141516
Произведение чисел равно 82361404007312676
Количество отрицательных чисел равно 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?