В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
пророк2345
пророк2345
25.01.2022 01:50 •  Информатика

1) напишите программу, которая спрашивает целые числа а и b и выводит на экран количество чётных и нечётных чисел в диапазоне от а до b 2)напишите программу, которая спрашивает целое число n , целые числа а и b,и выводит на экран n случайных чисел от а до b

Ответ:
bitvazat
bitvazat
07.10.2020 03:42
// PascalABC.NET 3.3, сборка 1561 от 02.11.2017
// Внимание! Если программа не работает, обновите версию!

1)

begin
  var (a,b):=ReadInteger2('Введите границы диапазона:');
  var Всего:=b-a+1; // количество целых чисел в диапазоне
  var Четных,Нечетных:integer;
  if a.IsOdd then begin Четных:=Всего div 2; Нечетных:=Всего-Четных end
  else begin Нечетных:=Всего div 2; Четных:=Всего-Нечетных end; // четное a
  Writeln('Нечетных- ',Нечетных,', четных- ',Четных)
end.

Пример
Введите границы диапазона: -4 4
Нечетных- 4, четных- 5

2)

begin
  var (n,a,b):=ReadInteger3('Введите n,a,b:');
  SeqRandom(n,a,b).Println
end.

Пример
Введите n,a,b: 15 -10 35
19 33 -10 4 5 -10 10 21 17 21 14 21 24 23 18
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?