В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
012003mariia
012003mariia
15.04.2023 06:19 •  Информатика

Написать программу на с++ 3. известен факториал числа (вводится с клавиатуры). найти это число.

Ответ:
kunakovdp06u5r
kunakovdp06u5r
07.10.2020 03:20
1.
#include <iostream>
using namespace std;

int main()
{
    int f, n, p;
    cin >> f;
    n = 0;
    p = 1;
    while (p<f) {
    n++;
    p*=n;
    }
    if (p==f) cout << n;
    else cout << "Ошибка ввода";
    system("pause");
}

2.
#include <iostream>
using namespace std;

int main()
{
    int f, n, p;
    cin >> f;
    p = 1;
    for (n=1; p<f; n++) p*=n;
    if (p==f) cout << n-1;
    else cout << "Ошибка ввода";
    system("pause");
}

Пример:
120
5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?