В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
den1112pro
den1112pro
04.10.2021 15:58 •  Информатика

Написать программу в c++ найти все простые числа в заданном пользователем диапазоне [a; b].

Ответ:
2345tgbkl
2345tgbkl
07.10.2020 03:11
#include <iostream>
#include <cmath>
using namespace std;
bool prost(int m){
int k = 0;
for (int i=2; i<=sqrt(m); i++)
if (m % i == 0) k++;
return k==0;
}

int main(){
    int a, b;
    cin >> a >> b;
    for (int i=a; i<=b; i++)
     if (prost(i)) cout << i << " ";
    return 0;
}

Пример:
5 20
5 7 11 13 17 19
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?