Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
EvGeniusYT
04.08.2021 07:16 •
Информатика
Написать программу о нахождении двухзначного числа а.найти сумму и произведение цифр данного числа,а также вывести новое число,в котором цифры числа а поменялись местами
Ответ:
NasFan
01.09.2020 10:47
Var a,a1,a2:integer;
begin
readln(a);
a1:=a div 10;
a2:=a mod 10;
writeln("Сумма цифр = ",a1+a2);
writeln("Произведение цифр = ",a1*a2);
writeln("Число наоборот: ",a2*10+a1);
end.
Пример:
25
Сумма цифр = 7
Произведение цифр = 10
Число наоборот: 52
0,0
(0 оценок)
Популярные вопросы: Информатика
БабаеваДарья
25.04.2023 18:53
Какие из команд присваивания записаны неверно а b*4: =2 b a: =3*b c c: = класс d класс : =c e b: =5...
Lukaeyrik05
10.02.2022 11:03
Вычислить сумму натуральных чисел не превосходящую заданное число а, while...
renatadautova
26.12.2022 22:33
Скакой системы счисления может существовать число 3210412.23...
2003Саша
16.08.2020 03:12
Огнем окружены редкие звери,амкрские лесные коты.изучить рисунок на стр 52 уч и составь план тушения .содержащий как можно меньше команд.набери воды...
jodydonig
16.08.2020 03:12
С1)является ли число b делителем числа a 2) определить площадь и периметр прямоугольного треугольника по двум сторонам 3) найдите корни квадратного уравнения ax2+bx+c=0...
Anna977497
17.04.2022 11:17
ответить на вопрос Что значит справедливость моей жизни? !! ...
нурик051
28.01.2020 18:08
Я сегодня добрая♥️вы знаете что делать ⛓️...
Inpeakfhdh
28.01.2020 18:08
Товар стоит 210 рублей. Скидка составляет 4/15 цены продукта. Какова стоимость товара со скидкой?...
svfedunina
01.06.2020 11:54
(x/y-2*sqrt(sqr(x)-4*x*y))/(x+y)+2*x Записать в общепринятом математическом виде...
ProstoSashaProsto
06.04.2023 04:39
Составить хронологическую таблицу Хакназар хан...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
readln(a);
a1:=a div 10;
a2:=a mod 10;
writeln("Сумма цифр = ",a1+a2);
writeln("Произведение цифр = ",a1*a2);
writeln("Число наоборот: ",a2*10+a1);
end.
Пример:
25
Сумма цифр = 7
Произведение цифр = 10
Число наоборот: 52