В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
semiglazova
semiglazova
30.10.2021 15:00 •  Информатика

Составить программу на языке паскаль. а) вычислить среднее арифметическое элементов массива а(20) равных за данному числу а. б) вычислить произведение модулей элементов массива а(20).

Ответ:
strange0311
strange0311
07.10.2020 02:54
Первая задача:
var
  i, c, sum: shortint;
  sr: real;
  m: array[1..20] of shortint;

begin
  sum := 0;
  readln(c);
  for i := 1 to c do
  begin
    readln(m[i]);
    sum := sum + m[i];
  end;
  sr := sum / c;
  sr := round(sr * 100) / 100;  //если округлять не нужно, удали эту строчку
  writeln('Среднее арифметическое: ', sr);
end.

Вторая задача:
var
  i, c: shortint;
  p: integer;
  m: array[1..20] of shortint;

begin
  p := 1;
  readln(c);
  for i := 1 to c do readln(m[i]);
  for i := 1 to c do p := abs(p * (m[i]));
  writeln('Произведение всех модулей массива: ', p)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?