Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
NastyuZnanija
29.04.2021 23:36 •
Информатика
Написать программу,которая вычисляет сумму первых n-натуральных чисел. должны быть операции while и do
Ответ:
Tytiki
16.08.2020 12:49
Var
i,n,s:integer;
begin
Write('n='); Read(n);
s:=0; i:=1;
while i<=n do begin
s:=s+i;
i:=i+1
end;
Writeln('Сумма равна ',s)
end.
Пример
n=10
Сумма равна 55
0,0
(0 оценок)
Популярные вопросы: Информатика
орпавераопрпираоарат
26.04.2021 15:42
Рисунок размером 64 на 256 пикселей закодирован с палитрой 4 цвета.сколько килобайт занимает в памяти рисунок без учёта сжатия?...
Аранида
30.01.2023 06:30
Вот вопрос перечислите основные операции с текстовыми файлами только этот один вопрос ответьте правильно я вас...
kristinavasina1
30.01.2023 06:30
1.в чем отличие прикладных программ от системных и инструментальных? 2.что входит в системное программное обеспечение? 3.что называется утилитой? 4.для чего предназначены драйвера?...
Dodod616
20.06.2021 11:03
Выбор: зовнішня загальна постійна оперативна...
linda281
25.05.2020 01:55
Поменять местами первый отрицательный и последний положительный элементы массива. Учесть возможность того, что отрицательных или положительных элементов в массиве может не быть.C++...
slipnot174
14.10.2021 21:47
Как избежать в лазарусе ошибки Runerror 103?...
Sveta1100
30.05.2022 12:55
выполнить арифметические действия в 8ричной и 16ричной системе счисления...
Top1lel
26.01.2022 08:12
Как рисовать в Python без специальных функций? На самом начальном уровне нарисуйте прямоугольник с звездочек (*)....
NikolayMakaren
02.02.2023 08:17
На рисунке ниже Сова учит Кота считать и просит его озвучить результат выполнения программы. Какое число назовёт Кот? когда нажат флажок.задать счет значение 17.повторить 10раз...
Littlebybigheart1111
26.08.2021 04:10
решить с Дано целое число операций деления нацело и взятия остатка от деления определить, имеются ли в записи числа N нечетные цифры. Если имеются, то вывести True, если нет...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,n,s:integer;
begin
Write('n='); Read(n);
s:=0; i:=1;
while i<=n do begin
s:=s+i;
i:=i+1
end;
Writeln('Сумма равна ',s)
end.
Пример
n=10
Сумма равна 55