В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
danier2
danier2
15.10.2022 20:18 •  Информатика

Составить программу.через двумерный массив. дана матрица а.сформировать вектор в,каждый элемент которого равен длине соответствующей строке матрицы а. длина строки считается по b1=√a11²+a12²+a13²+.. b2=√a21²+a22²+a23²+.. матрица вводится с клавиатуры.(pascal)

Ответ:
098714
098714
03.08.2020 22:18
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк в матрице:');
  var m:=ReadInteger('Количество столбцов в матрице:');
  Writeln('Вводите элементы матрицы построчно');
  var a:=new real[n,m];
  var b:=new real[n];
  for var i:=0 to n-1 do begin
    b[i]:=0;
    for var j:=0 to m-1 do begin
      Read(a[i,j]);
      b[i]+=Sqr(a[i,j])
      end;
    b[i]:=Sqrt(b[i])
    end;
  Writeln('Сформированный вектор');
  b.Println;
end.

Пример
Количество строк в матрице: 4
Количество столбцов в матрице: 3
Вводите элементы матрицы построчно
3.4 5.1 8
-1 0 1
-5.34 1.777 5
3 4 5
Сформированный вектор
10.0781942827076 1.4142135623731 7.52816903370268 7.07106781186548
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?