В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Shaha2000
Shaha2000
29.12.2022 15:48 •  Информатика

Впитоне напишите программу, которая определяет, является ли заданная строка (возможно, содержащая пробелы) палиндромом, то есть верно ли, что она после удаления пробелов читается одинаково слева направо и справа налево. входные данные входная строка – последовательность символов, возможно, содержащая пробелы. выходные данные программа должна вывести слово 'yes', если введённая строка – палиндром, и слово 'no', если она не является палиндромом. примеры входные данные ka za k выходные данные yes входные данные kaza n выходные данные no сдать:

Ответ:
лютебя
лютебя
08.09.2019 16:10
На примере в этой   program z1; uses crt; const st1='ма'; st2='ма'; var str: string; i,k: integer; begin write('введите строку: '); readln(str); for i: =1 to length(str) do if (st1=copy(str,i,2)) or (st2=copy(str,i,2)) then k: =k+1; writeln(k); end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?