Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
AWIKOZA
15.02.2023 16:21 •
Информатика
Дан массив. а(п). вывести в порядке следования: все отрицательные числа, затем все положительные числа. pascal
Ответ:
прорппп
26.08.2020 17:49
Заранее сорян, если накосячил c точками - запятыми и тд. (c++ one love)
program lolkekchebyrek;
var a[n], b, c, i : integer;
begin
read(n);
for i := 1 to n do begin
read(a[i]);
end;
for i := 1 to n do begin
if a[i] < 0 then begin
write(a[i], " ");
end;
for i := 1 to n do begin
if a[i] > 0 then begin
write(a[i], " ");
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ԺⱭNÍYⱭ
30.05.2022 21:13
Дорожный светофор с дополнительной секцией подает семь видов сигналов (непрерывные красный, желтый и зеленый, мигающие желтый и зеленый, красный и желтый одновременно,...
44444kobzarr1
28.06.2021 03:56
Как на пустой странице определить что есть деление на колонки? после деления на колонки вернуться к основному расположению текста можно: а. выбрав одну колонку, в....
МВ080706
01.02.2020 13:47
Определите значение переменной с после выполнения следующего фрагмента программы. ответ запишите в виде целого числа. а := 28 b := 10 а := 3 * b - а если а b то с...
ExploreYT
17.10.2021 14:38
Напиши рассказ про праздник новый год в 3 предложения...
vikaplmplmpl
17.10.2021 14:38
При каких значениях выражения 0,6-y 1,3-y будут равны 9 4,5...
Танюшксав
17.10.2021 14:38
Какими были азербайджан и грузия после распада ?...
lei123
17.10.2021 14:38
Поезд путь от одной станции до другой за 3,5 часа со скоростью 70 км\ч .с какой скоростью должен был бы идти поезд чтобы пройти этот путь за 4,9 ч...
Lusi28
17.10.2021 14:38
Докажите что прямые которые касаются окружности в концах его диаметра параллельны...
miakakashka
17.10.2021 14:38
Где больше всего распространён водород в свободном сомтоянии? а) в воздухе в)в космосе с)в природной воде д) в почве е) в растениях...
z0mD
17.10.2021 14:38
You/be (ever) you/be (when) you see (yet) you/be (how long) you/be (ever) he/be (when) he/know (how long) you/see (ever) you/see (when) you/visit (yet)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
program lolkekchebyrek;
var a[n], b, c, i : integer;
begin
read(n);
for i := 1 to n do begin
read(a[i]);
end;
for i := 1 to n do begin
if a[i] < 0 then begin
write(a[i], " ");
end;
for i := 1 to n do begin
if a[i] > 0 then begin
write(a[i], " ");
end;
end.