В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mimidoghoz
mimidoghoz
13.05.2022 16:28 •  Информатика

Решить в pascalabcnet. срок сдачи 21 октября 2017 г (составьте программу, которая проверяет оканчиваются ли вводимые числа на 5. составьте программу, которая проверяет: является ли вводимое число двузначным и равна ли сумма цифр числа 8.)

Ответ:
MuBuHa
MuBuHa
10.08.2020 15:54
Program n1;
var x: integer;
begin
    writeln('Введите число');
    readln(x);
    if (x mod 10 = 5) or (x mod 10 = -5) then
        writeln('Число оканчивается на 5')
    else
        writeln('Число не оканчивается на 5');
end.

program p2;
var x, y, sum: integer;
begin
    writeln('введите число');
    readln(x);
    if ((x >= 10) and (x <= 99)) or ((x <= -10) and (x >= -99)) then
        writeln('является двузначным')
    else
        writeln('не является двузначным');
    y := abs(x);
    sum := 0;
    while (y <> 0) do
        begin;
        sum := sum + (y mod 10);
        y := y div 10;
        end;
    if sum = 8 then
        writeln('сумма цифр равна 8')
    else
        writeln('сумма цифр не равна 8');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?