Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
zhenya2902
07.11.2020 13:33 •
Информатика
Водномерном массиве определить сумму четных чисел с использованием div или mod
Ответ:
бомба15682
26.08.2020 17:21
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
Writeln(a.Where(x->x mod 2=0).Sum)
end.
Пример
n= 13
4 -35 -9 -18 -36 -79 -80 -25 34 -7 93 -19 -92
-188
0,0
(0 оценок)
Популярные вопросы: Информатика
Ертилеу
06.01.2021 20:53
Дано четырехзначное число, если оно кратно 4, то посчитать сумму его цифр, иначе посчитать произведение цифр. составить программу на паскаль...
riathome26
26.10.2020 16:25
Сколько единиц содержится в двоичной записи значения выражения ? не могу понять, почему правильный ответ считается 45 (у меня получается 50)....
FullDown
31.01.2023 15:00
2. какое значение будет иметь переменная b после выполнения следующих операторов присваивания: a: =3; b: =a+9; b: =a+b; b: =a-b+b/a. 3. написать программу, которая...
Ivanych086
20.09.2021 02:17
Найдите значение логических выражений 1) ((1 ∨ 1) ∧ (1 ∧ 0) 2) ((1 ∧ 1) ∨ 0) ∧ (0 ∨ 1)...
nexorosheva06
06.03.2020 01:54
В электронной таблицы выделен диапазон из 12 ячеек , расположенный в столбцах F и G . Правый Нижний угол диапазона находится в ячейке G14. Запишите адрес диапазона...
katyakot2299
01.07.2020 10:04
Скласти рівняння реакції між mg і h2so4...
antoxa228322
01.07.2020 10:04
Дроби к общему знаменателю: а)1\2 и 1\3; б)1\2 и 1\7...
RedomR
01.07.2020 10:04
На каких энергетических уровнях нет d-подуровней? почему?...
milaboit
01.07.2020 10:04
Возьмите несколько одинаковых монет,сложите их так,как показано на рисунке 7, и измерьте линейкой,имеющей цену деления 1 мм,толщину получившейся стопки.определите...
aminoshkina
01.07.2020 10:04
Укакого из оксидов оксидов массовая доля кислорода самая большая: cu2o, cuo?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
Writeln(a.Where(x->x mod 2=0).Sum)
end.
Пример
n= 13
4 -35 -9 -18 -36 -79 -80 -25 34 -7 93 -19 -92
-188