В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Malifisen
Malifisen
02.10.2022 06:19 •  Информатика

Написать программу в pascal даны целые числа . если в данной последовательности ни одно четное число не расположено после нечетного.то получить все отрицательные члены последовательности иначе-положительное.

Ответ:
2005NeZnayka2005
2005NeZnayka2005
24.05.2020 00:41

var
a: array[1..50] of integer;
i,f, n: integer;

begin
write('n=');
readln(n);
for i := 1 to n do
begin
write('a', i, '=');
readln(a[i]);
end;
f := 0;
writeln;
for i := 1 to n - 1 do
if (a[i] mod 2 <> 0) and (a[i + 1] mod 2 = 0) then f := 1;
if f = 0 then
begin
for i := 1 to n do
if a[i] < 0 then write(a[i]:4);
end
else
for i := 1 to n do
if a[i] > 0 then write(a[i]:4);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?