В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lybchikfreed
lybchikfreed
02.10.2022 06:19 •  Информатика

Составить программу печатающие числа от -50 до 50 в обратном порядке,увеличивающее каждое число в 10 раз.

Ответ:
alisakiseleva2
alisakiseleva2
24.05.2020 00:40

program;

var

max,val: integer;

label

start, ends; 

begin 

max:=-50;

val:=50;

start:

if val>max then val:=val-10

if val=max then goto ends; 

goto start; 

ends:

end. 

0,0(0 оценок)
Ответ:
бб0бб
бб0бб
24.05.2020 00:40

Вот на C:

 

#include <stdio.h>

int main(void)
{
  int i;
  for(i = 50; i >= -50; i -= 10)
  {
   printf("%d\n", i); 
  }

  printf("\n");
  system("pause");
  return 0;
}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?