Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
льоха7
27.07.2020 01:08 •
Информатика
Заполнить одномерный массив 5 элементами случайным образом в диапазоне от -10 до 10 .вычислить произведение элементов массива .произведение -288
Ответ:
lezifequliyeva
06.10.2020 23:21
//PascalABC.Net
//(c) NaaMan
var
a : array of integer;
n, i : integer;
p : real;
begin
n := 5;
a := new integer[n];
a := ArrRandom(n, -10, 10);
p := 1;
for i:= 0 to n-1 do
if a[i] < 0 then p *= a[i];
println(a);
writeln('Произведение всех отрицательных равно ', p)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
invation
18.09.2021 12:48
Паскаль .вывести квадраты всех чисел от a до b. ( значения а и b вводятся с клавиатуры; b =a).для выполнения организовать цикл с предусловием....
struk20022298
18.09.2021 12:48
Напишите , все типы файлов расширения !...
kolobok2000
08.04.2020 23:20
Вычислить значение переменной z для значения а, равных 2,3,. z=3,5t^2-7cost+1,6 . t=sin(4a). для выполнения организовать цикл с предусловием.паскаль....
Deniz1337
08.04.2020 23:20
Ошибка 504- что это , и как с этим бороться ?...
myrzik5293p081ps
14.02.2022 06:32
Написанное письмо состоит из 78 символов. Каков размер письма в битах, байтах? Можете только ответ!...
Morenova123456
10.06.2021 03:55
Определите значение переменной «a» после выполнения фрагмента программы:a := 10; b := 10; if a b thenb := b + 12 elsea := a - 7;if a b thena :=a + 12;...
mru199
21.11.2021 06:52
2. Ниже приведён алгоритм, чему будет равно s после выполнений данного алгоритма? Var a: array[1..10] of integer; i: integer; s: real; Begin s:=0; For i:=1 to 10 do s:=s+i;...
TANJASELIK
01.01.2022 01:24
решите Практическая работа №4: Найдите разность между суммой квадратов и квадратом суммы первых ста чисел. Практическая работа №5: Братья Вилли Билли и Дилли пошли на поиски...
Lesawolk12
26.12.2022 23:24
1. Определить значение переменных а и b: b: =8 b:= div(a,b) c:=mod(a, b)...
BabyTaya
25.07.2021 11:06
Дан угол MON, равный 47°. Через вершину О проведен перпендикуляр ОК к стороне OM. Какой может быть величина угла KON?137° или 43°90° или 47°90° или 1379137° или 47°90° или 43°...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
//(c) NaaMan
var
a : array of integer;
n, i : integer;
p : real;
begin
n := 5;
a := new integer[n];
a := ArrRandom(n, -10, 10);
p := 1;
for i:= 0 to n-1 do
if a[i] < 0 then p *= a[i];
println(a);
writeln('Произведение всех отрицательных равно ', p)
end.