В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gta518
gta518
14.03.2022 02:23 •  Информатика

Используя процедуру нахождения корней квадратного уравнения,написать программу нахождения корней биквадратного уравнения.паскаль.выполнить через procedure.

Ответ:
baseke2018
baseke2018
20.08.2020 22:53
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

procedure (a,b,c:real; var Корни:(real,real);
    var ЧислоКорней:integer);
begin
  if a=0 then ЧислоКорней:=0
  else begin
    var D:=b*b-4*a*c;
    if D>0 then begin
      var p1:=-b/2/a; var p2:=Sqrt(D)/2/a;
      Корни:=(p1-p2,p1+p2);
      ЧислоКорней:=2
      end
    else
      if D=0 then begin
        var p1:=-b/2*a;
        Корни:=(p1,p1);
        ЧислоКорней:=1
        end
      else ЧислоКорней:=0
    end
end;

begin
  var (a,b,c):=ReadReal3('Коэффициенты биквадратного уравнения a,b,c:');
  var Корни:=(0.0,0.0);
  var ЧислоКорней:=0;
  (a,b,c,Корни,ЧислоКорней);
  if ЧислоКорней=0 then Writeln('Нет корней')
  else begin
    var НомерКорня:=1;
    var r:=Корни[0];
    if r>0 then begin
      Writeln('x1=',-Sqrt(r),', x2=',Sqrt(r));
      НомерКорня:=3
      end
    else
      if r=0 then begin
        Writeln('x1=0');
        НомерКорня:=2
        end;
    r:=Корни[1];
    if r>0 then
      Writeln('x',НомерКорня,'=',-Sqrt(r),', x',НомерКорня+1,'=',Sqrt(r))
    else
      if r=0 then Writeln('x',НомерКорня,'=0');
    end
end.

Примеры
Коэффициенты биквадратного уравнения a,b,c: 1.25 -5 -13.7
x1=-2.42235751307744, x2=2.42235751307744

Коэффициенты биквадратного уравнения a,b,c: 4 -5 1
x1=-0.5, x2=0.5
x3=-1, x4=1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?