Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
fkfofo02
14.09.2021 21:44 •
Информатика
Составить программу если число положительное, извлечь квадратный корень, в другом случае взвести в квадрат.
Ответ:
Soulwax
06.10.2020 22:26
Program z123;
var a:real;
begin
readln(a); //Вводим число
If a>0 then //Проверяем
a:=Sqrt(a) //Вычиляем
else
a:=Sqr(a); //Вычисляем
writeln(a); //Выводим
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Foxamel
05.06.2022 10:54
Синформатикой. нужно объяснение по информатике. 1)каков минимальный объём видеопамяти, необходимый для хранения графического изображения, занимающего область экрана 512 на 512...
fatowka84
05.06.2022 10:54
Напишите программу, которая получает с клавиатуры натуральное число и определяет, простое оно или нет. для этого нужно делить число на все натуральные числа, начиная с 2, пока...
boha3
05.06.2022 10:54
Научите переводить из биты в байты, килобайты,, мегабайты, гигабайты. что в измеряется битами, байтами, килобайтами ,мегабайтами , гигабайтами?...
ДарьяКаракал
30.03.2022 10:38
На строительство квартиры в банке был взят кредит в сумме 80тыс. белорусских рублей под 15% годовых на срок 25 лет. Сколько денег в месяц нужно выплачивать банку,чтобы вовремя...
EvkShaih
14.04.2021 01:54
Заполните пропуски,чтобы нарисовать данную фигуру...
8951992masha
16.05.2020 21:03
Какую фигуру нарисует черепашка при y=30 и z=50?...
onexochu
16.02.2020 20:56
Вычислите кол-во вещества и массу оксида алюминия, образовавшегося в результате взаимодействия 130 г алюминия с достаточным кол-вом кислорода (4Al + 3O2 =2Al2O3)...
yanaskazka777
15.02.2020 12:19
Який об`єм водню (н.у.) виділився внаслідок взаємодії алюмінію, масаякого становила 10,8 г, із сульфатною кислотою?...
AiratAitov
10.06.2021 11:39
Як людина використовує бактерії?...
664565465
31.03.2022 17:38
Представьте ввиде многочлена: (а-3) ²...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a:real;
begin
readln(a); //Вводим число
If a>0 then //Проверяем
a:=Sqrt(a) //Вычиляем
else
a:=Sqr(a); //Вычисляем
writeln(a); //Выводим
end.