Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
adochka777
05.05.2021 20:20 •
Информатика
Дан массив из n чисел. составить программу для вычисления суммы элементов массива, имеющих чётные индексы. паскаль
Ответ:
школьницаиркутск
06.10.2020 22:17
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
Write('Сумма элементов с четными индексами ',
a.Where((x,i)->i.IsOdd).Sum)
end.
Пример
n= 13
81 6 -34 -33 -13 86 -14 -49 -28 -20 -93 5 -62
Сумма элементов с четными индексами -5
0,0
(0 оценок)
Популярные вопросы: Информатика
незнаю177
31.12.2020 10:13
Надо написать программу в турбо паскале которая выводит на экран таблицу умножения числа на нечетные числа от 3 до 15....
foton228
18.01.2020 19:12
Яболел я хз как решпать. сделать с решением 70...
EkimovaVlada
28.04.2022 02:39
VBA Составьте программу VBA для нахождения из трех произвольных чисел A, B, C, задающих длины сторон треугольника, площади треугольника, если треугольник существует, в противном...
PolinaPilipenco
03.08.2021 16:33
Класс 2 часть стр. 38 10. зарание огромное ! у каких предметов или существ могут быть такие отличительные признаки? (запиши как можно больше названий рядом с каждым признаком)...
amelisova06
17.02.2020 20:08
Мәдениетті мәдениетті қоғам кепілі эссе...
Karton2288
25.05.2022 11:47
Сказка для младших школьников как появился первый самолет...
nigar26
23.04.2020 09:48
Берілген сөздердің синонимдерін тауып, мағынасын ашыңдар.салдары, шарана, алдағы өміріне , түйсініп , титімдей....
kirana05
23.04.2020 09:48
Политические лидерства алихана букейханова...
solovyevadasha
25.06.2021 02:46
Какие корни у слов маляр малюет шипит шипучка шипы шиповник...
dhkbzdyjnxx
09.07.2020 05:13
Между какими соседними целыми числами на координатной прямой заключено число0,3; - 7,8; 3 5/8 ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
Write('Сумма элементов с четными индексами ',
a.Where((x,i)->i.IsOdd).Sum)
end.
Пример
n= 13
81 6 -34 -33 -13 86 -14 -49 -28 -20 -93 5 -62
Сумма элементов с четными индексами -5