В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Tikhon228
Tikhon228
05.05.2021 00:47 •  Информатика

Используя оператор case , напишите программу, которая переводит десятичные числа 1, 5, 10, 50, 100, 500, 1000, считываемые с клавиатуры, в римские.

Ответ:
404678
404678
24.05.2020 00:36

include <iostream>

using namespace std;

int main()

{int n;

 cin >> n;

switch(n)

        {case 1:cout<<"I";break;

         case 5:cout<<"V";break;

         case 10:cout<<"X";break;

         case 50:cout<<"L";break;

         case 100:cout<<"C";break;

         case 500:cout<<"D";break;

         case 1000:cout<<"M";break;

        }

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?