В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Впаскале составить программу для ввода с клавиатуры 7 целых чисел. вывести на экран: 1) элементы массива с положительными значениями. 2)элементы массива с нечетными значениями 3)элементы массива, значения которых положительны и кратны 5

Ответ:
НадюшаLOVEYOU
НадюшаLOVEYOU
06.10.2020 21:51
// PascalABC.NET 3.3, сборка 1541 от 29.09.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger('Введите 7 целых чисел:',7);
  Write('Положительные: '); a.Where(x->x>0).Println;
  Write('     Нечетные: '); a.Where(x->x.IsOdd).Println;
  Write('Положительные, кратные 5: '); a.Where(x->(x>0) and (x mod 5=0)).Println
end.

Пример
Введите 7 целых чисел: -5 6 21 15 -20 40 0
Положительные: 6 21 15 40
     Нечетные: -5 21 15
Положительные, кратные 5: 15 40
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?