В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
fakersot
fakersot
10.01.2022 11:23 •  Информатика

Язык c++.задано натуральное число n. напишите программу, которая определяет количество натуральных чисел, не больше n и не делятся ни на одно из чисел 2, 3, 5. входные данные: число n (1 ≤ n ≤ 1000000000). выходные данные: найденное число пример input output 10 2 обратите внимание на то что программа проверяется компилятором ,и он не должен показывать ошибки.

Ответ:
ulyanae17
ulyanae17
06.10.2020 21:24
#include <iostream>
using namespace std;

int main()
{
    int n;
    int k=0;
    cout << "n = ", cin >> n, cout << "\n";
    for (int i=1; i<=n; i++) {
    if ((i%2 != 0)&&(i%3 != 0)&&(i%5 != 0)) k++;
    }
    cout << k << "\n";
    return 0;
}

Пример:
n = 10
2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?