Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
андрей100500ый
04.12.2020 12:20 •
Информатика
C++. напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел.
Ответ:
Bong144
09.09.2020 20:29
#include <iostream>
#include <vector>
#include <algorithm>
#include <iterator>
using namespace std;
int main()
{
cout << "Enter num: " << endl;
vector<int> array(istream_iterator<int>(cin), { });
for (auto i : array) {
cout << i << " ";
}
auto result = min_element(array.begin(), array.end()) - array.begin();
cout<< "Min element: " << array.at(result);
return 0;
}
Ввод: 12 96 33 9 45
Вывод: 9
0,0
(0 оценок)
Популярные вопросы: Информатика
123456789Ad1jssjsj
22.11.2022 00:33
Какая шина используется для подключения принтеров, сканеров, цифровых камер и других периферийных устройств?...
on82
22.11.2022 00:33
Введите с клавиатуры 4 числа, выведите их среднее арифметическое, сумму, произведение....
найлешка
22.11.2022 00:33
Найти разность двух наименьших из трех чисел c++. завтра зачет и надо сдать будет....
Kfhjrhnf
07.04.2023 22:14
1. Какие программы, предназначенные для 3D -графики вы знаете? Перечислите 2. Сходства и различия 2D и 3D технологий3. Перечислите инструменты рисования в программе SSketchUp...
тупая1294
15.07.2021 20:47
Приведите три примера объектов, которые очень просто разложить на составные части...
ReginaRem27
30.08.2020 10:06
2. Каким инструментом можно изменить угол просмотра изображення? Укажите номер инструмента. [1 1 2 3 4 второе задание сделать срок сдачи очень маленький...
000Ангел000
14.01.2022 18:12
Творческая работа по повести А. де Сент-Экзюпери «Маленький принц» Расположи по порядку отдельные части, пункты, подпункты цитатного плана повести сказки «Маленький принц»....
MilаKlimenkova
18.01.2021 07:18
Какие слова можно написать в кроссворде по информатике на тему текст?...
trahtrah1
18.01.2021 07:18
Надо записать программу в паскале для вычисления 2x в степени n,где использовать n до 100,а x от 1 до 30...
Dеn4ik
19.01.2023 23:55
3. Какие виды носители информации ты знаешь?Это...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <vector>
#include <algorithm>
#include <iterator>
using namespace std;
int main()
{
cout << "Enter num: " << endl;
vector<int> array(istream_iterator<int>(cin), { });
for (auto i : array) {
cout << i << " ";
}
auto result = min_element(array.begin(), array.end()) - array.begin();
cout<< "Min element: " << array.at(result);
return 0;
}
Ввод: 12 96 33 9 45
Вывод: 9