В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nuraaaykaaa
Nuraaaykaaa
23.11.2021 18:38 •  Информатика

Написать программу, которая будет принимать числа от пользователя до тех пор пока не будет введен ноль. после того как пользователь ввел все числа она должна вывести сумму всех введенных чисел и произведение, возведенное в квадрат. dim a, b, c as single 'c -это произведение 'b- это сумма b = 0 c = 1 for i = 1 to 10000 console.write("введите a= ") a = console.readline if a > 0 and a < 0 then b = b + a c = c * a else b = b ^ 2 c = c ^ 2 end if next console.writeline("b=" & b & "с=" & c) console.readline() что не так? не могу понять.

Ответ:
saaaasss01
saaaasss01
06.10.2020 20:10
Делайте что-то типо
int m = 1;
while(true) // нескончаемый цикл
{
cout << "Enter number: " << endl; // просим ввести число
cin >> m;
if (m == 0) // проверяем равно ли 0
{
// если да(т.е. мы встретили 0), тут делаем  нужные вычисления
break; // и уже потом выходим из цикла
}
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?