В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Zhenkyaaaa
Zhenkyaaaa
17.06.2020 14:29 •  Информатика

С++ напишите программу, которая вводит два вещественных числа (x и y) и вычисляет значение x^y.

Ответ:
семенггвп
семенггвп
20.08.2020 22:10
#include <iostream>

int main()
{
    float x, y;
    float res = 1;
    std::cin >> x >> y;
    for (int i = 0; i < y; i++)
        res *= x;
    std::cout << res << std::endl;
}
0,0(0 оценок)
Ответ:
ДианаDi1111
ДианаDi1111
20.08.2020 22:10
function Power(x,y:real):real;
{ (C) Puporev }
begin   if x=0 then     Power:=0  
else    
if x>0 then      
 Power:=exp(ln(x)*y)  
  else      
 Power:=-exp(ln(abs(x))*y);
end;
  var  x,y:real;
begin
 readln(x,y);
 writeln(power(x,y));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?