В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aska13aska
aska13aska
20.06.2020 20:02 •  Информатика

Синформатикой напишите программу, которая запрашивает четырёхзначное число, разрезает его пополам и выводит половинки через пробел. sample input 1: 1234 sample output 1: 12 34 sample input 2: 1200 sample output 2: 12 00 напишите программу, которая запрашивает пятиразрядное число и выводит число, составленное из цифр данного числа взятых задом наперёд. sample input 1: 12345 sample output 1: 54321 sample input 2: 12000 sample output 2: 21

Ответ:
linassglazunov
linassglazunov
26.08.2020 15:17
#include <iostream>using namespace std;int main() {  int a, b, c, d;  cin >> a;  b = a/100;  c = a%100;  cout << b << " " << c;  return 0;}
но есть проблема, переменные типа int сокращает 00 до 0
и на выводе получается не 12 00, а 12 0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?