В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ilya70228
ilya70228
30.09.2021 13:17 •  Информатика

2. дан текстовый файл. напишите программу, в которой считывается информация построчно и вызывается функция, подсчитывающая количество слов в строке, которые с первым словом.

Ответ:
Ашеашачочєо
Ашеашачочєо
06.10.2020 13:56
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

function LexRepeat(Self:string):(string,integer); extensionmethod;
begin
  Writeln(Self);
  var aw:=Self.MatchValues('\b\w+\b').ToArray;
  if aw.Count>1 then
    Result:=(aw[0],aw[1:].Where(w->LowerCase(w)=LowerCase(aw[0])).Count)
  else Result:=(aw[0],0)
end;

begin
  ReadLines('Pushkin2.txt').Select(s->s.LexRepeat)
      .Where(x->x[1]>0).Foreach(x->Writeln('*** ',x[0],' - ',x[1]+1,' ***'))
end.

Пример работы программы

Александр Пушкин
К***
Я помню чудное мгновенье:
Передо мной явилась ты,
Как мимолетное виденье,
Как гений чистой красоты.
В томленьях грусти безнадежной,
В тревогах шумной суеты,
Звучал мне долго голос нежный
И снились милые черты.
Шли годы. Бурь порыв мятежный
Рассеял прежние мечты,
И я забыл твой голос нежный,
Твои небесные черты.
В глуши, во мраке заточенья
Тянулись тихо дни мои
Без божества, без вдохновенья,
*** Без - 2 ***
Без слез, без жизни, без любви.
*** Без - 3 ***
Душе настало пробужденье:
И вот опять явилась ты,
Как мимолетное виденье,
Как гений чистой красоты.
И сердце бьется в упоенье,
И для него воскресли вновь
И божество, и вдохновенье,
*** И - 2 ***
И жизнь, и слезы, и любовь.
*** И - 3 ***

Во вложении - исходный файл Puskin2.txt
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?