В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу, язык pascal. ввести целое положительное число трехзначное число n. разбить это число на разряды (найти число сотен, десятков и единиц). найти сумму разрядов числа n

Ответ:
nselt
nselt
26.08.2020 14:08
Program razrad;
  var n,a,b,c,s: integer;
begin
  write('введите положительное трехзначное число - '); readln(n);
  a:=n mod 10; {последняя цифра}
  b:=(n div 10) mod 10; {средняя цифра}
  c:=n div 100; {первая цифра}
  writeln('сотен - ', с, ', десятков -',b,', единиц - ',a);
  s:=a +b+c:
  writeln('сумма цифр числа - ',s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?