В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
simakanna
simakanna
17.01.2023 22:14 •  Информатика

Составьте программу, определяющие самых жарких 7 дней и самых холодных 7 дней месяца, если известна среднесуточная температура за каждый день.

Ответ:
NikkiLee
NikkiLee
06.10.2020 13:52
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(31,16,27); a.Println;
  var s:=a.Select((x,i)->(x,i)).OrderBy(x->x[0]).Select(x->x[1]+1);
  Write('Семь самых холодных дней: '); s.Take(7).Println;
  Write('Семь самых жарких дней: '); s.TakeLast(7).Println
end.

Пример
17 17 25 27 22 26 22 23 26 26 25 16 21 25 22 17 20 19 16 19 21 22 19 16 21 27 22 24 22 24 22
Семь самых холодных дней: 12 19 24 1 2 16 18
Семь самых жарких дней: 11 14 6 9 10 4 26
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?