Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
chestnut3342
29.12.2020 15:25 •
Информатика
Вычислить среднее арифметическое элементов массива с(14)
Ответ:
Popopoghdhz
06.10.2020 13:47
// PascalABC.NET 3.2, сборка 1485 от 15.06.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(14,-99,99); a.Println;
Writeln('Среднее арифметическое равно ',a.Average)
end.
Пример
64 -26 -70 -42 86 46 -72 -6 82 56 52 14 41 -97
Среднее арифметическое равно 9.14285714285714
0,0
(0 оценок)
Ответ:
temamojet1997
06.10.2020 13:47
Код Pascal:
Const
N = 14;
Var
C:array[1..N] of integer;
i:integer;
S:real;
Begin
Randomize;
Write('C(',N,'):');
S:=0;
For i:= 1 to N do
Begin
C[i]:=random(21)-10;
Write(' ',C[i]);
S:=S+C[i]
End;
WriteLn;
Write('Sr(C) = ',S/N);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
10040
03.06.2021 05:31
1) Напишите программу, которое получает с клавиатуры пятизначное число и удаляет из негопервую и последнюю цифру, например, из числа12345 должно получится 234.2) Напишите...
кисуня208
26.03.2020 23:09
Описывать назначение видов памяти компьютера...
fil3853tima
12.09.2020 22:25
Чтобы перемещаться по тексту, можно использовать клавиши управления курсором: - клавишу используют для постраничного перемещения по экрану вниз; - клавишу обычно используют...
suleymanovrusl
13.06.2020 06:26
Определи вид компьютерной сети...
Сенси
25.10.2020 11:55
Выполняем в тетради Запиши в тетрадь названия и назначения известных тебеинструментов.информатика...
denver87
06.06.2022 22:20
найти средне арифметическре положительных элементов линейного массива. данная задача имеет смысл, если массив заполнен не только положительными числами, но также содержит...
bodnari2121bodn
29.01.2021 22:57
решите это Арифметические действия в 8-ричной и 16-ричной системах счисления....
Мухосранск462
18.12.2021 11:59
ответьте на вопросы. 1. какую роль в информационной деятельность человек выполняют органы чувств? перечислите их 2. почему восприятие вкусов и запахов можно назвать приёмом...
sasharomanov03
25.03.2021 06:06
.Устройства, не входящие в состав системного блока...
yaksyta
14.05.2022 18:24
Составьте кроссворд включая слова память, компьютер, диск, процессор, экран, монитор, внешняя, информация, передача....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(14,-99,99); a.Println;
Writeln('Среднее арифметическое равно ',a.Average)
end.
Пример
64 -26 -70 -42 86 46 -72 -6 82 56 52 14 41 -97
Среднее арифметическое равно 9.14285714285714
Const
N = 14;
Var
C:array[1..N] of integer;
i:integer;
S:real;
Begin
Randomize;
Write('C(',N,'):');
S:=0;
For i:= 1 to N do
Begin
C[i]:=random(21)-10;
Write(' ',C[i]);
S:=S+C[i]
End;
WriteLn;
Write('Sr(C) = ',S/N);
End.