В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

7.написать программу на паскале вычисления значения функции (х^2 при х> 0 х-12 при х≤0) 8.написать программу на паскале нахождения периметра произвольного четырехугольника, данные вводить с клавиатуры. 9.написать программу на паскале вычисления значения выражения у=15х3+3х2-6 10.написать программу на паскале вычисления значения функции (х^2+5х-4 при х> 3 х при х≤3)

Ответ:
Королина2022
Королина2022
06.10.2020 13:50
//7.Написать программу на Паскале вычисления значения функции(х^2 при х>0 х-12 при х≤0)

var
x:integer;
begin
writeln('Введите x');
readln(x);
if x>0 then writeln('ответ ', power(x,2))
else writeln('ответ ', x-12);
end.

//8.Написать программу на Паскале нахождения периметра произвольного четырехугольника, данные вводить с клавиатуры.

var
a,b,c,d:integer;
begin
writeln('Введите a,b,c,d');
readln(a,b,c,d);
writeln('P= ', a+b+c+d);
end.

//9.Написать программу на Паскале вычисления значения выражения у=15х3+3х2-6

var
x:integer;
begin
writeln('Введите x');
readln(x);
writeln('ответ ', 15*power(x,3)+3*power(x,2)-6)
end.

//10.Написать программу на Паскале вычисления значения функции(х^2+5х-4 при х>3х при х≤3)

var
x:integer;
begin
writeln('Введите x');
readln(x);
if x>3 then writeln('ответ ', power(x,2)+5*x-4)
else writeln('ответ ', x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?