В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
olegohremenko
olegohremenko
17.02.2023 11:50 •  Информатика

Напишите программу на языке паскаль! с клавиатуры вводится три четырёх значных числа. найти сумму нечётных цифр в наименьшем числе.

Ответ:
LexaCR7
LexaCR7
06.10.2020 13:38
Var
  a, b, c, sum: integer;

function min(x, y: integer): integer;
begin
  if(x > y) then result := y
  else result := x;
end;
 
begin
  sum := 0;
  read(a, b, c);
  a := min(a, min(b, c));
  while a > 0 do
  begin
    if(a mod 10 mod 2 <> 0) then sum := sum + a mod 10;
    a := a div 10;
  end;
  write(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?