Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Зуев693
16.08.2021 14:53 •
Информатика
Написать программу на с++ надо вывести из строки со словами разделенными пробелами , вывести слова в которых буквы не повторяются
Ответ:
daaanila2015
06.10.2020 13:35
#include<iostream>
#include<string>
using namespace std;
int main()
{
string S;
cout << "BBEDITE TEXT: ", getline(cin,S);
S+=' ';
string Slovo = "";
for (int i = 0; i < S.length(); i++)
{
if (S[i] != ' ') Slovo+=S[i];
else
{
bool B = 1;
for(int j = 0; j+1 < Slovo.length(); j++)
{
for(int m = j+1; m < Slovo.length(); m++)
{
if (Slovo[j] == Slovo[m]) B = 0;
}
}
if (B) cout<<"\n" <<Slovo;
while (S[i] == ' ') i++;
Slovo=S[i];
}
}
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
26040717
25.07.2021 22:40
Угодайте слова в ребусе ( рис 5. 2)....
MariaSet010203
26.10.2020 17:48
Примеры (примеры должны быть разными ): достоверной информации. объективной информации. неактуальной информации . полезной информации. актуальной информации ....
akmsulu
12.03.2022 22:42
Зашифруйте слово компьютер графическим...
AvtOriaAnn
06.02.2020 05:01
Как связаны развитие технологий и информационное развитие общества?...
njjjjjjtgl
13.12.2021 17:35
Скорость передачи данных через adsl - соединение равна 512000бит/с. передача файла через это соединение заняла 60 секунд. определите размер файла в кбайт....
snqa
12.12.2021 06:26
Определите скорость передачи данных в кб/с для отправки в сети 129 мб информации за 8 минут...
irinatalanina95
12.12.2021 06:26
Как зашифровать графическим слово компьютер...
EdgyHuman
12.12.2021 06:26
Будь-ласка зробіть рівняння 64*біт=128байт...
Ротср
12.12.2021 06:26
Зашифруйте слово компьютер графическим символьными числовым...
Kseniya05
28.10.2020 04:48
Сообщение о различных видах сохранения и передачи информации....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include<string>
using namespace std;
int main()
{
string S;
cout << "BBEDITE TEXT: ", getline(cin,S);
S+=' ';
string Slovo = "";
for (int i = 0; i < S.length(); i++)
{
if (S[i] != ' ') Slovo+=S[i];
else
{
bool B = 1;
for(int j = 0; j+1 < Slovo.length(); j++)
{
for(int m = j+1; m < Slovo.length(); m++)
{
if (Slovo[j] == Slovo[m]) B = 0;
}
}
if (B) cout<<"\n" <<Slovo;
while (S[i] == ' ') i++;
Slovo=S[i];
}
}
return 0;
}