В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Олег4311
Олег4311
07.11.2021 23:14 •  Информатика

Составить программу - тест, которая запрашивает имя и предлагает ответить на три вопроса. отвечать можно "да" или "нет". при вводе другого ответа - возврат к вопросу. в итоге программа выдает количество верных ответо

Ответ:
khana3
khana3
06.10.2020 13:32
Var
   O:string;
   i,k:byte;
   B,pO:array[1..3] of string;
Begin
B[1]:='2 * 2 = 5 ?';pO[1]:='нет';
B[2]:='Оператор Read вводит данные?';pO[2]:='да';
B[3]:='СССР победил в войне 1812 года?';pO[3]:='нет';
k:=0;
For i:= 1 to 3 do
    Begin
    WriteLn(B[i]);
    ReadLn(O);
    O:=LowerCase(O);
    While (O <> 'да')and(O <> 'нет') do
       Begin
       Write('Попробуйте ещё раз: ');ReadLn(O);
       O:=LowerCase(O);
       End;
    if pO[i] = O then k:=k+1;
    End;
WriteLn('Количество правильных ответов: ',k);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?