В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vorobeowmikhai
vorobeowmikhai
22.04.2022 19:00 •  Информатика

Разработать подпрограмму для вычисления суммы двух комплексных чисел использовать разработанную подпрограмму для вычисления суммы n комплексных чисел. значение n вводится с клавиатуры. решить!

Ответ:
// PascalABC.NET 3.2, сборка 1483 от 14.06.2017
// Внимание! Если программа не работает, обновите версию!

function ReadComplex:Complex;
begin
  var (r,i):=ReadReal2;
  Result:=cplx(r,i)
end;

procedure WriteComplex(x:Complex);
begin
  if x.Imaginary=0 then Write(x.Real)
  else begin
    if x.Real<>0 then Write(x.Real);
    if (x.Imaginary>0) and (x.Real<>0) then Write('+');
    Write(x.Imaginary,'i')
    end
end;

begin
  var n:=ReadInteger('N =');
  Writeln('Введите ',n,' комплексных чисел');
  Writeln('Формат ввода числа: действ.часть, пробел, мнимая часть');
  var s:=cplx(0.0,0.0);
  loop n do s+=ReadComplex;
  Write('S='); WriteComplex(s)
end.

Пример
N = 5
Введите 5 комплексных чисел
Формат ввода числа: действ.часть, пробел, мнимая часть
2.3 -3.12
-1.7 8
6.14 0.2
-2.4 -3.2
0 1.6
S=4.34+3.48i
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?