В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Motiby19
Motiby19
25.09.2020 23:23 •  Информатика

Составьте программу формирования и вывода на экран одномерного массива , состоящего из количества положительных элементов строк двумерного массива.

Ответ:
Черныйангел01
Черныйангел01
06.10.2020 13:07
Код Pascal:

Const
   N = 3;
   M = 4;
Var
   A:array[1..N,1..M] of shortint;
   B:array[1..N] of byte;
   i,j,k:byte;
Begin
Randomize;
For i:= 1 to N do
    Begin
    k:=0;
    For j:= 1 to M do
        Begin
        A[i,j]:=random(21)-10;
        Write(A[i,j]:3,' ');
        if A[i,j] > 0 then k:=k+1;
        End;
    B[i]:=k;
    WriteLn;
    End;
WriteLn;
For i:= 1 to N do
    Write(B[i],' ')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?