В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
кот1555
кот1555
04.06.2022 06:19 •  Информатика

Составить программу в с++ дан массив размера n и целые числа k и l (1 < k ≤ l ≤ n). найти сумму всех элементов массива, кроме элементов с номерами от k до l включительно.

Ответ:
aidar2002032
aidar2002032
06.10.2020 13:06
#include <iostream>#include <iomanip>#include <ctime>
using namespace std;
int main(){ setlocale(LC_ALL, "RUSSIAN"); const int N = 10; int arr[N]; int K, L, sum = 0, sumexcl = 0; srand(time(NULL)); for (int i = 0; i < N; i++) { arr[i] = rand() % 10; sum += arr[i]; } cout << "Введите K >> "; cin >> K; cout << "Введите L >> "; cin >> L; for (int i = 0; i < N; i++) { cout << arr[i] << " "; if((i>=K) && (i<=L)) sumexcl += arr[i]; } sum -= sumexcl; cout << "Результат: " << sum << endl; system("pause");}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?