Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
lanamuradyamu
15.03.2022 23:06 •
Информатика
Составьте программу для решения следующей : дан массив из 20 элементов, заполненныей случайными числами . найти минимальный элемент массива и его номера
Ответ:
Vika47696
03.08.2020 14:50
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "RUSSIAN");
const int arr_len=20;
int arr[arr_len];
int i = 0;
srand(8120);
for (i = 0; i < arr_len; i++)
{
arr[i] = rand() % 100;
cout << arr[i] << ' ';
}
cout << endl;
int min = 100, min_index=arr[0];
for (i = 0; i < arr_len; i++)
{
if (arr[i] < min)
{
min = arr[i];
min_index = i;
}
}
cout << "Минимальный элемент массива: " << min << endl;
cout << "Его индекс: " << min_index << endl;
system("pause");
}
0,0
(0 оценок)
Популярные вопросы: Информатика
kgatikha1
07.05.2023 03:01
В чём заключалась цель Латышских стрелков?...
УмНяша01
22.02.2023 23:43
She jumped off the bus while it . (already started, had already started, would already start)...
GriefSS
17.11.2021 18:34
4-(5х-1) +5=3(х-2)Скажите мне как это решить♀️...
artandr2212
09.03.2023 12:28
Переведите следующие предложения на немецкий 1. Я кладу мою одежду в шкаф. Теперь она в шкафу. 2. Положи книги на стол. Теперь они лежат на столе. 3. Повесь фотографию...
aimsen
08.11.2021 15:12
Каждый день 6 лошедям и 12 коровам даёться 120 кг корма корм котрый даёться 5 лошадям больше корма,который даёться 6 коровам на 9 кг. Сколько корма даёться каждый...
nazarshariu77
29.12.2021 05:52
1 I am looking forward to (see) you. 2 He dreads (have) to retire. 3 I arranged (meet) them here. 4 He urged us (work) faster. 5 I wish (see) the manager. 6 It s no...
инна1903
10.08.2021 00:46
яка густина тіла якщо при повному зануренні у нас на нього діє архвмедова сида що дорівнює половині сили тяжіння...
Пелагея14
20.04.2021 13:05
4 класс Першого дня автобус здійснив 8 рейсів, а другого - 6. Другого дня він перевіз на 84 пасажири менше ніж першого. Скільки пасажирів перевез першого дня, якщо...
катя5062
20.04.2021 13:05
теплохід проплив течією 209км і проти течії -124км. Скільки часа потрібно теплоходу на весь шлях якщо його власна швидкість 34,5км/год, а швидкість течії 3,5 км/год...
aliksondrrr3
08.12.2021 20:01
Приведите примеры конфликтов ! 1) социально-бытовой (в то же время не относящийся к семье) 2) слабовыраженные, вялотекущие (когда один избегает другого) 3) слабовыраженные,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main()
{
setlocale(LC_ALL, "RUSSIAN");
const int arr_len=20;
int arr[arr_len];
int i = 0;
srand(8120);
for (i = 0; i < arr_len; i++)
{
arr[i] = rand() % 100;
cout << arr[i] << ' ';
}
cout << endl;
int min = 100, min_index=arr[0];
for (i = 0; i < arr_len; i++)
{
if (arr[i] < min)
{
min = arr[i];
min_index = i;
}
}
cout << "Минимальный элемент массива: " << min << endl;
cout << "Его индекс: " << min_index << endl;
system("pause");
}