В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
leeesy664
leeesy664
30.01.2022 12:34 •  Информатика

Составьте программу для вычисления числа n: n = 1∙2∙3∙…∙х. число х вводится с клавиатуры.

Ответ:
danilaandriyanov
danilaandriyanov
06.10.2020 12:27
function factorial(n : integer) : BigInteger;
var 
   i : integer; 
   f : BigInteger;
begin   
     f := 1;   
     for i := 2 to n do     
         f := f * i;   
     factorial := f
end;

var
x:integer;

begin
write('X: ');
readln(x);
writeln(factorial(x));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?