Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
NastyaVoitelnicha
30.01.2022 12:34 •
Информатика
16. составьте программу для вычисления числа n: n = 1∙2∙3∙…∙х. число х вводится с клавиатуры.
Ответ:
Загадака
06.10.2020 12:37
function factorial(n : integer) : BigInteger;
var
i : integer;
f : BigInteger;
begin
f := 1;
for i := 2 to n do
f := f * i;
factorial := f
end;
var
x:integer;
begin
write('X: ');
readln(x);
writeln(factorial(x));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Катядонецк
10.05.2020 16:03
чи можуть в пам яті комп ютера одночасно перебувати папки з однаковими іменами або файли з однаковими іменами та розширеннями?...
Izilaevapolina
08.05.2020 03:06
В Excel начертить график y=sin(x) с шагом 0,1 для аргумента от -1 до 5...
sfdfgdfgdfg
07.12.2021 16:00
При a=1 значение переменной a равно , при a=11 значение переменной a равно...
solomiaoleksin
07.12.2021 16:00
Так как вопросов 3 и они сложные 60 ! 1. графическое изображение размером 10 на 5 см отсканировано с разрешением 300 dpi и имеет глубину цвета 8 бит. определите его информационный...
валерия20156
12.02.2023 22:44
ответьте на вопрос: Что такое архиватор? Что такое разархивация? Что такое сжатие информации? Напиши название программ архивирования....
lenusj1975197514
02.07.2021 03:44
Что дает выбор опции SFX-архив в процессе архивации?...
Аделина2605
13.08.2022 01:39
Раскройте скобки, употребляя present simple, past simple, future simple. 1. he (to go) to the theatre tomorrow. 2. we always (to go) to school in the morning. 3. kate (not to go) to...
nastyasergeeva9
13.08.2022 01:39
Закончи эти вопросы по образцу do you eat plums you eat plums or bananas? do your frinds like to ski...
mariy2104
13.08.2022 01:39
Сделать звуки буквеный анализ слова облако...
matvienko14
13.08.2022 01:39
Чем можно объяснить что одни птицы улетают на юг, а другие остаются зимовать на родине...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
i : integer;
f : BigInteger;
begin
f := 1;
for i := 2 to n do
f := f * i;
factorial := f
end;
var
x:integer;
begin
write('X: ');
readln(x);
writeln(factorial(x));
end.