В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SirErikBoss
SirErikBoss
27.11.2020 07:09 •  Информатика

1. составьте программу в pascal abc. известно, что x кг конфет стоит a рублей. определить, сколько стоит 1 кг и y кг этих же конфет. 2. составьте программу в pascal abc. дано двузначное число. найти сумму и произведение его цифр. 3. составьте программу в pascal abc. дано двузначное число. вывести число, полученное при перестановке цифр.

Ответ:
linka737
linka737
06.10.2020 12:03
1.
var a: real;
      x,y: integer;
begin
         readln(x,a,y);
         writeln('1 kg konfet stoit ', a/x:1:2);
         writeln(y,' kg konfet stoyat ', a/x*y:1:2);
         readln;
end.
2.
var a,s,p: integer;
begin
         readln(a);
         s:=a mod 10 + a div 10;
         p:=(a mod 10)*(a div 10);
         writeln(s);
         writeln(p);
         readln;
end.
3.
var a,b: integer;
begin
         readln(a);
         b:=(a mod 10)*10+(a div 10);
         writeln(b);
         readln;
end.
Это если без циклов.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?