В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lover7
lover7
18.12.2021 13:28 •  Информатика

Напишите программу по последовательному вводу пяти различных чисел чисел. причём программа не должна разрешать ввод одинаковых чисел.

Ответ:
Вот листинг: 

"if freedom is outlawed, only outlaws will have freedom." © TSRh

Напишите программу по последовательному вводу пяти различных чисел чисел. причём программа не должна
0,0(0 оценок)
Ответ:
hamidullinelnar
hamidullinelnar
06.10.2020 11:37
Const
   N = 5;
Var
   P:array[1..N] of integer;
   C,i,j,B:integer;
Begin
WriteLn('Введите пять целых чисел');
For i:=1 to N do
    Begin
    Repeat
    B:=0;
    Read(C);
    For j:= 1 to i-1 do
        if P[j] = C then B:=j;
    if B > 0 then WriteLn('Число ',P[B],' уже было'#13'Попробуйте ещё раз')
    else P[i]:=C;
    Until B = 0;
    End;
WriteLn('Полученная последовательность');
For i:= 1 to N do Write(P[i],' ')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?