Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
vitalinabelova1
05.04.2021 12:34 •
Информатика
Даны цифры числа. собрать их в число.(паскаль турбо) количество элементов массива < =10000
Ответ:
Крутойбрат
06.10.2020 11:26
Var
N,i:integer;
C:array[1..10000] of byte;
Begin
Write('Введите количество цифр: ');
ReadLn(N);
if N > 0 then
Begin
For i:= 1 to N do
Read(C[i]);
i:=1;
While (C[i] = 0)and(i<=N) do
i:=i+1;
For i:= i to N do
Write(C[i])
End;
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
Danil21K
02.07.2021 23:10
Какая формула записана неверно?Варианты ответа =A1^5*B2= A1*5B2=A1*($B2-A2)=A1/B2/B...
влад2299
14.09.2020 14:10
С++ с клавиатуры вводится целое число. если введенное число отрицательное, то возвести его в квадрат , оставить число без изменений в противном случае....
Maia55444
25.12.2021 02:20
ХЕЛП Проанализируй и выбери верный ответ. PROGRAM norm; VAR A:INTEGER; B: REAL; C: CHAR; PROCEDURE D (P1: REAL; P2: CHAR); BEGIN (*Начало работы процедуры *) END; (*Конец процедуры*)...
innamatvijchuk
25.12.2021 02:20
Среди приведённых ниже трёх чисел записанных в десятичной системе счисления найдите число сумма цифр которого в шестнадцатеричной записи наименьшая. В ответе запишите сумму цифр...
5Kamilla505
07.03.2023 00:53
Между населенными пунктами A,B,C,D,F построены дороги,протяжённость которых (в километрах) приведена в таблице....
Islikzaziy
08.02.2021 03:56
ЛЮДИ По одному из наглядных изображений выполните чертеж детали в трех видах, М1:1. Нанесите размеры....
СнежанаВолк
11.05.2020 14:50
Текст подготовлен для передачи по сети и содержит 206 символов. Каждый символ кодируется двумя байтами и во избежание искажений передается трижды. Время передачи текста составило...
Shmanin32
13.10.2022 16:37
Начало | a:=14,b:=9,c:=6 | (a-b) c a:=c-b a:=b-c | | | a | Конец с информатикой.Очень нужно! Нужно вычислить переменную по блок схеме. Очень вас Начало | a:=14,b:=9,c:=6 | (a-b)...
Masha3334
14.02.2020 11:18
Рассмотренные алгоритмы можно реализовывать и по-другому. Определите, код какого алгоритма приведён ниже: for i in range(n - 1): for j in range(i + 1, n): if arr[i] arr[j]: arr[i],...
matvey9874
14.06.2021 12:54
Дан список из 10 элементов: 8 1 7 4 3 9 2 5 6 10 Как будет выглядеть список после 3-х шагов вставки в алгоритме сортировки вставками? Введите список чисел, разделённых пробелами....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
N,i:integer;
C:array[1..10000] of byte;
Begin
Write('Введите количество цифр: ');
ReadLn(N);
if N > 0 then
Begin
For i:= 1 to N do
Read(C[i]);
i:=1;
While (C[i] = 0)and(i<=N) do
i:=i+1;
For i:= i to N do
Write(C[i])
End;
End.