Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Katri1921
16.01.2022 11:05 •
Информатика
Pascal написать программу, переводящую десятичное число в двоичную систему
Ответ:
moyutot
06.10.2020 11:11
Var
A:longint;
B:string;
Begin
Write('A = ');
ReadLn(A);
A:=Abs(A);
While A > 0 do
Begin
if A mod 2 = 0 then B:='0'+B
else B:='1'+B;
A:=A div 2
End;
WriteLn(B)
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
artamasvan
11.10.2020 10:31
Найдите сумму всех натуральных чисел меньше 7 pascal...
finn10
27.02.2021 03:46
Составить программу для вычисления группы элементов однородного массива c состоящего из 25 натуральных чисел, которые не меньше 10. организовать заполнения массива числами не большими...
nenftd
09.01.2020 09:01
Вавтобусе 50 мест, которые обычно нумеруются числами от 1 до 50. вышло новое распоряжение, согласно которому код места не должен содержать цифр, а может состоять только из букв...
LIZETTA111
09.01.2020 09:01
1. а. найдите в списке шесть пар объектов, связанных отношениями входит в состав . определите в каждой паре, какой объект является частью другого: колесо комната обод стол автомобиль...
PavlWhite249
09.01.2020 09:01
Перечислить параметры страницы текстового документа...
Антонио789176
09.01.2020 09:01
1заполните пропуски числами: а) 5 кбайт = байт = бит б) кбайт = байт = 12288 бит в) кбайт = байт = 213 бит г) гбайт = 1536 мбайт = кбайт = байт 2 книга, набранная на компьютере,...
Violetta2004w
09.06.2021 13:59
Задания №1. Напишите определение. Интерфейс – Задания №2. Заполните пропушенное в таблице.Задания №3. Напишите математическое выражение в Python.Математическое выражениеЗапись...
margusqw
20.07.2020 15:48
кроссворд по программе Скретч ключевое слово Скретч...
АлексаФокс
07.11.2022 14:19
5. Каково значение калия в жизнедеятельности клетки?...
kumalena73
01.05.2020 18:09
Ақпараттардың «ақиқат» немесе «жалған» екендігін анықта. Адам аттарының ішінде бек, хан, мырза, құл, әлі (ғали, əли) сияқты сөздермен жасалған есімдер бөлекжазылады...Дүние жүзілік,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
A:longint;
B:string;
Begin
Write('A = ');
ReadLn(A);
A:=Abs(A);
While A > 0 do
Begin
if A mod 2 = 0 then B:='0'+B
else B:='1'+B;
A:=A div 2
End;
WriteLn(B)
End.