В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kignkfleh
kignkfleh
17.05.2020 02:07 •  Информатика

Написать программу вычисления стоимости покупки с учетом скидки. скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% — если сумма больше 1000 руб. (c#)

Ответ:
evolved
evolved
06.10.2020 11:11
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace СиШарп
{
    class Program
    {
        static void Main(string[] args)
        {
            Console.Write("Сумма покупки: ");
            double S = int.Parse(Console.ReadLine());
            if (S > 500)
            {
                if (S > 1000) S *= 0.95;
                else S *= 0.97;
                Console.WriteLine("Сумма покупки с учётом скидки: {0:0.00}",S);
            }
            else Console.WriteLine("Скидка не предоставляется");
            Console.ReadKey();
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?