В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
musmus11
musmus11
18.12.2020 08:08 •  Информатика

Составьте программу для вычисления произведения целых чисел, их среднее арифметическое до тех пор пока не будет введён 0 используя цикл repeat

Ответ:
chizhvlad2003p017q2
chizhvlad2003p017q2
06.10.2020 11:05
 Var
   A,S,P:real;
   k:integer;
Begin
S:=0;
P:=1;
k:=-1;
Repeat
Read(A);
if A <> 0 then P:=P*A;
S:=S+A;
k:=k+1;
Until A = 0;
WriteLn('P = ',P);
WriteLn('Sr = ',S/k);
ReadLn
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?