Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
vovakornev2002
29.07.2022 12:17 •
Информатика
Написать программу в паскале. задано натуральное число n (n ≤ 9999). определить количество цифр числа n^2.
Ответ:
lizaivleva201
06.10.2020 10:43
Первый
Var n:longint;
Begin
Write('n = ');ReadLn(n);
n:=n*n;
if frac(Ln(n)/Ln(10)) > 0 then WriteLn(int(Ln(n)/Ln(10))+1)
else WriteLn(Ln(n)/Ln(10))
End.
Второй
Var
n,k:longint;
Begin
Write('n = ');ReadLn(n);
k:=0;
n:=n*n;
While n > 0 do
Begin
k:=k+1;
n:=n div 10
End;
WriteLn(k);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
zzsasz33
14.06.2021 17:33
Проверить, есть ли в данной строке одинаковые символы....
natalyasergeev1
16.05.2020 07:27
Напишите программу, которая вводит два целых числа, a и b (a...
Regisha1981
16.05.2020 07:27
Напишите программу, которая вводит два целых числа, a и b (a...
Cuba125
24.08.2020 13:23
Виділити одночасно кілька суміжних об єктів не можна за таких дій. а)з використанням миші, виділяючи прямокутну область екрана. б) з використанням комбінації клавіші...
132132456789
21.01.2020 03:47
Програмні засоби комп‘ютерної графіки...
PolinaRa1610200710
22.08.2022 02:40
Сообщение о том,что из корзины с разноцветными шарами(все шары разного цвета) достали зелёный шар, содержит 4 бита информации. сколько шаров было в корзине?...
SteveDog86
06.12.2021 05:47
Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел: (10, 6); (7, 6); (–4, 3); (2, 9); (12, 7);...
АВатар1765
12.10.2022 13:11
Определите тип данных переменной «а». а=4 ptint(type(a)...
rashas05
25.02.2022 07:33
Какие возможности среды программирования Scratch используются при разработке анимации ? ...
akimfugenko
20.08.2021 13:59
Продолжительность жизни дуба 1500 лет, у берёзы в 0,1 раза, а у сливы в 0,01 раза меньше, чем у дуба. Сколько лет живут берёза и слива?DUMLoДубБерёзаСливаВерных...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Var n:longint;
Begin
Write('n = ');ReadLn(n);
n:=n*n;
if frac(Ln(n)/Ln(10)) > 0 then WriteLn(int(Ln(n)/Ln(10))+1)
else WriteLn(Ln(n)/Ln(10))
End.
Второй
Var
n,k:longint;
Begin
Write('n = ');ReadLn(n);
k:=0;
n:=n*n;
While n > 0 do
Begin
k:=k+1;
n:=n div 10
End;
WriteLn(k);
End.