В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nastyzotova12378
nastyzotova12378
19.05.2022 09:50 •  Информатика

Составить программу на pascal: 1) для нахождения суммы 2^2+4^2+ 2) для нахождения всех делителей числа n

Ответ:
timofeyfrol
timofeyfrol
06.10.2020 10:43
Var
   n,i:integer;
   S:real;
Begin
Write('n = ');ReadLn(n);
WriteLn('1)');
S:=0;
i:=2;
While i<=n do
   Begin
   S:=S+i*i;
   i:=i+2;
   End;
WriteLn('S = ',S);
WriteLn('2)');
Write(n);
i:=n div 2;
While i > 0 do
   Begin
   if n mod i = 0 then Write(' ',i);
   i:=i-1
   End;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?