В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dianaorlova00
dianaorlova00
09.04.2022 11:47 •  Информатика

1)дано трехзначное число.составьте программу которая определяет а)является ли сумма его цифр нечетным числом 2)составьте программу в которой осуществляется вот целых чисел до тех пор пока не будет введен 0 и подсчет а)количество чисел оканчивающихся на 6 и кратных 4 б)сумма чисел оканчивающихся на 6 и кратных 4 на языке паскаль

Ответ:
seregapomogite
seregapomogite
06.10.2020 10:47
1)
Program hhh54;
var x:longint;
begin
  read (x);
  if ((x div 100) + ((x div 10) mod 10) + (x mod 10)) mod 2 <> 0 then write ('ЯВЛЯЕТСЯ')
  else write ('НЕ ЯВЛЯЕТСЯ');
end.

2)
а)
Progran hhh54;
var i,k,x:longint;
begin
  k:=0;
  read (x);
  while x <> 0 do
    begin
      if (x mod 10 = 6) and (x mod 4 = 0); then k:=k+1;
      read (x);
    end;
  write (k);
end.

б)
Progran hhh54;
var i,s,x:longint;
begin
  s:=0;
  read (x);
  while x <> 0 do
    begin
      if (x mod 10 = 6) and (x mod 4 = 0); then s:=s+x;
      read (x);
    end;
  write (s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?