В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kilernosok
kilernosok
10.05.2020 03:01 •  Информатика

Дано трехзначное число. составьте программу которая определяет а)кратна ли 5 сумма его первой и последней цифры б) сумма квадратов чисел в диапазоне от 1 до n в) количество натуральных чисел не превышающих 50 и кратных 3

Ответ:
marinatabeleva4
marinatabeleva4
06.10.2020 10:37
a)
Program hhh54;
var x: longint;
begin
  read (x);
  if ((x div 100) + (x mod 10)) mod 5 = 0 then write ('КРАТНА')
  else write ('НЕ КРАТНА');
end.
б)
Program hhh54;
var s,n,i: longint;
begin
  s:=0;
  read (n);
  for i:= 1 to n do
    s:=s+sqr(i);
  write (s);
end.
в)
Program hhh54;
var k,n,i: longint;
begin
  k:=0;
  for i:= 1 to 50 do
    if i mod 3 = 0 then k:=k+1;
  write (k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?